Page 1 of 1


PostPosted: Tue Jun 17, 2008 1:52 pm
by 9balldotcom
Polomint who is one of VPHQ Tournament Directors has developed a small programme in his efforts to get those of us who have Routers and cannot get Virtual Pool 3DL to run on Gamespy.

The major problem for a lot of people who no doubt have purchased Vp3 in the past and come to the Gamespy Lobby,is that they cannot get Virtual Pool 3 to run due to the fact that they have to manually open ports in their router in order to let the game run.

This has to be the most annoying thing about making a purchase of the VP3DL buy it,you install play offline no problem at all and then when you try to join the online community you find your stumped by the fact that you need a degree in routers in order to try and get the game working.

Now I can speak personally of the problems with routers as I have a BT Hub which only through help from the lobby I got the game working through my router.

Many people like myself who are total Router novices need a way of sorting this out.

Virtual Pool 3DL needs specific ports opened in your router in order to work through Gamespy and unless you understand the terminology involved and even though you can look at instructions online about your router,it is for most people a total confusing thing to try and mess with a router for fear of not being able to get online or causing major problems when your messing with something you know very little about.

I would not be suggesting this programme without having done a full test on it myself.

However.....there are some things you should be aware of prior or downloading this programme.

If like my router,you can create a backup of the configuration of your router....YOU SHOULD DO SO PRIOR TO TRYING THIS PROGRAMME.By doing so you will have saved the initial settings of your router as it was set when you first installed it...IE YOU WILL BE ABLE TO USE YOUR BACKUP TO RESET YOUR ROUTER.

So first thing I did was to reset my router to factory settings in order to try Polomints programme,so this I did but only after having already downloaded his programme to my desktop.

Then I followed the instructions on Polomints webpage and the programme opened up and did what it said it would confirmed "PORTS OPENED"

So then after that,there was only one thing to try.....try and create a VP3DL game room......I did and it worked and you can see your room listed in the lobby.

So the last thing to do after that try and join a room.....this I did and YES it worked also.

In conclusion,If this programme can do what it says it does for many more people for Virtual Pool 3DL players,then I can only recommend it to as a major source of help to many potential players online.

At the moment this remains a BETA version please use it at your own risk and neither Polomint,Celeris nor me are liable or responsible.....if it totally fecks your router up.

It didnt do it to what do you think?


PostPosted: Wed Jun 18, 2008 4:29 am
by sharkey9
Make sure you have UPnP enabled in your OS aswell.

For XP:

Rightclick Network Neighbourhood on Desktop-->properties-->menu - advanced-->optional components-->mark "Networking tools"-->click details-->check "UPnP"

PostPosted: Wed Jun 18, 2008 8:36 am
by polomint77
Good point sharkey.. although it is normally enabled by default on most XP installations.. some software does turn it off tho...

PostPosted: Thu Jun 19, 2008 4:01 am
Nice work polomint,works fine for me,very handy little program indeed

PostPosted: Fri Jun 20, 2008 4:55 pm
by polomint77

If you use this software then please take note of the make and model of your router. Then please let me or 9balldotcom know those details and if it worked or not. Also, please note that this is still only test software, results may vary depending on your system configuration.
Windows Vista 64 is currently NOT supported, and any configurations of Windows XP that have been stripped of essential services/programs may also not work (eg XPlite installations), but still let me know.

If it doesn't work the first time, then please make sure you have the .net framework v2 installed (the link is on that webpage,
Also, make sure that you have followed the instructions on the webpage *to the letter*.

Only then give error reports directly to me via or post them here..

Thank you.

PostPosted: Sat Jun 21, 2008 7:24 pm
by vpeer
Thanks for putting this together.

I'm not a big fan of uPnP, it has security issues and I doubt it will be as well supported in the future. But for how with XP, you have a solution that should get more people running.

I'm also not a big fan of using Windows Firewall unless your on a lan and need protection from users on the lan. A properly setup router/firewall should be sufficient.

I would change the wording on your site for "firewall" to "windows firewall" as that was initially confusing to me as I think of most home routers as firewalls too. When you think the port opening software is sufficiently tested please send me a link and I will incorporate into the VP3 install.

PostPosted: Sun Jun 22, 2008 7:17 am
by polomint77
I would change the wording on your site for "firewall" to "windows firewall"


PostPosted: Wed Jun 25, 2008 4:09 pm
by 9balldotcom
Posts not relating to this post either in this section or anywhere else in the forum are simply going to be removed.So making silly inane posts will not survive long...they will be removed.Those that persist in making stupid posts will also be removed from the forum

PostPosted: Fri Aug 15, 2008 2:06 pm
by ComboSchtap
Oh, finally I remembered the password to write something in here.

So, I will try to be short...

I can enter into an existing room, but I just cannot set a room.

My rooter does not have a firewall open and the windows firewall is not set as well. I still cannot set a room.

I tried your program, but it does not work...

Also when I enter to a room and all the other players leave the room, the room dissapears from the lobby!!! As if I cannot "carry" the room by myself.

Any suggestions?

PostPosted: Fri Aug 15, 2008 3:11 pm
by 9balldotcom
Yes it is very important that you fully understand Polos instructions before you try using the router programme.
If you havent followed those instructions,thats also a likely cause to why it didnt work.
That however can be discussed with you in the lobby if you want any further assistance


PostPosted: Fri Oct 03, 2008 7:29 am
by ShafTraX
Hi man - to all guys -

Cant play anymore -

My situation is like this

My ISP Provider is a wireless one

And they only give private IP wich is bad

Ive talk to the support on my ISP Provider well - they dont open ports even
Ive been angry about it and they didnt said that the internet they will provide me has no public IP

Polo's Software doesnt work - cause i dont have the router in my hand -

I dont know if the one on my roof top is a router - Its called CANOPY - a motorolla device that enables me to connect to my ISP provider via wireless

I know this will happen if i resigned at work - lolz - formerly im connecting to my office to get a public ip so i can play - but now i cannot.

I dont know if theres a solution but - i hope so - im stuck with this provider for 6 months and its the only Broadband available to our area.

I hope theres an alternative way - cause i miss playing

Best Regards,