VP4 with Wine on Linux

General discussion for anything related to the Virtual Pool 3 DL game play including Career, Tournaments, Computer Opponents, Trick Shots, and Quick Play.

Moderator: 9balldotcom

Post Reply
timseal
Wannabe
Wannabe
Posts: 2
Joined: Tue May 29, 2012 3:07 pm

VP4 with Wine on Linux

Post by timseal » Mon Sep 17, 2012 7:56 pm

I have VP4 running under Wine, on ArchLinux. This could mean it runs on MacOS too, but I have not tried it.

Here is what I did to get past the various problems.
This is not intended to be a guide for all hardware, it's to describe one working setup. Mine.
It might solve a problem or two for others, which is why I'm writing all this. I will answer questions here too, unless my answer is "I don't know".

1. Update: The rawinput patch was merged into Wine in version 1.5.13, so you probably don't need to worry about this bit.
If you are running Wine version <=1.5.12, the Raw Input patch for Wine itself is needed to get the mouse to work when you're at the table.
(This might be the most useful thing I discovered.) I'm using Arch, so I built it from the AUR package. PlayOnLinux can download a build for you, I think - I didn't try it myself though.


2. I used winetricks to install various dlls.

Code: Select all

amstream
d3dx9 (This installed the d3dx9_xx below)
d3dx9_26 28 31 35 36 39 42 (Probably only need d3dx9_42)
devenum
dinput8
dxdiagn
dxdiag
msvcirt
quartz
vcrun6sp6
vcrun6
xinput

3. In winecfg:
a) On the Libraries tab, I have the following overrides:

Code: Select all

amstram (native)
d3dx9_42 (builtin, native)
d3dx9_43 (builtin, native)
devenum (native)
dxdiag.exe (native)
dxdiagn (native)
quartz (native)
xinput1_1 (builtin, native)
xinput1_2 (builtin, native)
xinput1_3 (builtin, native)
xinput9_1_0 (builtin, native)
b) On the Graphics tab, I have none of the four checkboxes selected. All are unchecked.
The Windows version is set to Windows XP.


4. driconf
If you don't have the Intel GM965 card, the following is probably useless. Look at the docs for your card before trying any of this stuff.
My graphics card is:

Code: Select all

00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (secondary) (rev 0c)
according to lspci.
I was getting a game screen with cue, but invisible balls on an almost completely black table.
This fixed the problem: I ran driconf, and on the Image Quality tab changed 'Enable S3TC texture compression even if software support is not available' to Yes.
driconf is just an editor for the file ~/.drirc. This is my complete .drirc:

Code: Select all

<driconf>
    <device screen="0" driver="i965">
        <application name="Default">
            <option name="force_s3tc_enable" value="true" />
            <option name="no_rast" value="false" />
            <option name="always_flush_cache" value="false" />
            <option name="early_z" value="false" />
            <option name="stub_occlusion_query" value="false" />
            <option name="shader_precompile" value="false" />
            <option name="always_flush_batch" value="false" />
            <option name="bo_reuse" value="1" />
            <option name="texture_tiling" value="true" />
            <option name="force_glsl_extensions_warn" value="false" />
            <option name="vblank_mode" value="1" />
            <option name="allow_large_textures" value="2" />
            <option name="fragment_shader" value="true" />
        </application>
    </device>
</driconf>

5. VP4 itself
The updater didn't work when I tried to go from 4.0.3 to 4.0.5. If you don't have the full installer for the latest version, get it from the download page and use that to install.

In VP4 itself, I have the following settings in Graphics:

Code: Select all

Video Mode: 1440x900x32 (This is the max for my machine. Full screen)
Brightness: 5 (Sometimes it gets a bit dark, I can change this with no problems)
Vertical Sync: On  (when I change this, everything crashes)
FPS limit: 120
AntiAliasing: None (The buttons are disabled for me, probably because of my driconf)
Anisotropy: 1 (High numbers seem to slow things down, and it looks worse too.)
Texture Res: High
Poly Count: High

6. Finally, I always run vp4 from a terminal like this: (I've tried doubleclicking the icons etc, but it didn't work for me.)

Code: Select all

tim ~/.wine/drive_c/Program Files/Celeris/Virtual Pool 4 $ wine vp4.exe

Good luck. VP4 is worth it.

-Tim
Last edited by timseal on Sat Sep 29, 2012 7:02 pm, edited 1 time in total.

Hanterp
Banger
Banger
Posts: 235
Joined: Fri Dec 26, 2008 4:55 pm

Re: VP4 with Wine on Linux

Post by Hanterp » Tue Sep 18, 2012 3:15 am

Should this also work under Ubuntu?
Looks like a hell of a job to get it done, if you have only general knowledge of Linux.

Post Reply